lunes, 2 de abril de 2012

DIGITO DE VERIFICACION DIAN _ INFORMACION EXOGENA


DIGITO DE VERIFICACION



 
El digito de verificación que la DIAN da a las personas es un número de identificación único que se le entrega a cada persona correspondiente a varios factores que atañen su número de identificación, para identificar este digito necesitamos una formula con multiplex caracteres que el Excel no nos permite, es por ello que necesitamos dividirla en dos para obtener el numero.

Para ello a continuación muestro la primera parte y podría decir la más importante de este proceso, la parte resaltada de rojo (“NIT”) va la dirección de la celda que contiene el valor NIT, por ejemplo “A2”, “D4”, “E8”.


FORMULA 1


=RESIDUO((VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),15,1))*3+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),14,1))*7+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),13,1))*13+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),12,1))*17+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),11,1))*19+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),10,1))*23+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),9,1))*29+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),8,1))*37+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),7,1))*41+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),6,1))*43+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),5,1))*47+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),4,1))*53+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),3,1))*59+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),2,1))*67+VALOR(EXTRAE(TEXTO(“NIT”,"000000000000000"),1,1))*71),11)



Posteriormente en otra celda recomendablemente contigua ira la siguiente formula, mucho más corta pero que define el número final de acuerdo a dos condicionales SI.


=SI (“FORMULA 1”=0,0,SI(“FORMULA 1”=1,1,11-C2))

 En esta es reemplazar la palabra “FORMULA 1” por la correspondiente a la dirección de la formula anterior, por ejemplo “C2”

=SI(C2=0,0,SI(C2=1,1,11-C2))


Como observamos la Celda C2 va hacer la que arroje el resultado, en ese caso seria conveniente ocultar la celda B2, Dando clic derecho en la letra B y seleccionando ocultar, de esta forma cada vez que cambio la A2, veré el resultado o digito de verificación al lado.

 Con el fin de poder ser de ayuda para la información exógena adjunto plantilla en Excel en donde con simplemente pueden copiar las formulas y adaptarlo a un formato preestablecido por ustedes, este archivo no será bloqueado por este fin.

 Recuerden que antes de utilizarlo prueben la efectividad con varios NIT que ustedes ya conozcan el resultado, para comprobar que de pronto no se haya ido incompleta la formula en el momento de adaptación o al momento de que el autor haya generado este archivo



No hay comentarios:

Publicar un comentario en la entrada